{ inputs, lib, config, pkgs, ...}: {
imports = [
./hardware-configuration.nix
./hypervisor.nix
];
nix = {
extraOptions = ''
experimental-features = nix-command flakes
'';
registry = lib.mapAttrs' (n: v: lib.nameValuePair n { flake = v; }) inputs;
};
boot.loader = {
systemd-boot = {
enable = true;
};
efi.canTouchEfiVariables = true;
timeout = 1;
};
networking = {
hostName = "essos";
#wireless.enable = true;
firewall.enable = true;
networkmanager.enable = true;
hosts = {
"10.1.1.1" = [ "essos" ];
};
};
time.timeZone = "America/Sao_Paulo";
i18n.defaultLocale = "en_US.UTF-8";
console = {
font = "Lat2-Terminus16";
keyMap = "dvorak";
};
users.users = {
elise = {
isNormalUser = true;
extraGroups = [ "wheel" "libvirtd" ];
shell = pkgs.zsh;
};
};
programs.gnupg.agent = {
enable = true;
enableSSHSupport = true;
};
programs.zsh.enable = true;
services = {
openssh = {
enable = true;
passwordAuthentication = true;
};
logind.lidSwitch = "ignore";
};
system.stateVersion = "22.11";
}